www.winretro.com

GIMP

NameDiscriptionLink
1.2.5 Requires gtk runtime version 1.3.0
2.2.10 Works on Windows 98 and ME while it is not officialy supported, requires gtk2 runtime
2.6.7 Last version that supports Windows 2000
Details > GIMP
Copyright © WinRetro 2022 2024